Voice Routing Platform Cutover
Scheduled for April 10, 2025 at 8:00 AM – 9:00 AM
Affects
Voice Services
Under maintenance from 8:00 AM to 9:00 AM
Completed
April 10, 2025 at 9:00 AMCompleted
April 10, 2025 at 9:00 AMMaintenance has completed successfully
In progress
April 10, 2025 at 8:00 AMIn progress
April 10, 2025 at 8:00 AMMaintenance is now in progress
Planned
April 10, 2025 at 8:00 AMPlanned
April 10, 2025 at 8:00 AMWe will be performing a scheduled maintenance to cut over from our current voice routing platform to a new system.
Our teams will be actively monitoring the transition to ensure minimal impact and a smooth migration.
If you experience any issues after the maintenance, please reach out to our support team.