Broadsource SecureCall - Service Disruption : SecureCall Services (US East Region) – Incident details
All systems operational
Service Disruption : SecureCall Services (US East Region)
Resolved
Major outage
Started 9 days agoLasted about 2 hours
Affected
Payment Services
Major outage from 8:36 AM to 10:24 AM
Voice Services
Major outage from 8:36 AM to 10:24 AM
Updates
Resolved
Resolved
AWS reports conditions have improved, and most services are now operational. SecureCall Services are also working normally, and we will continue to monitor for stability.
Identified
Identified
We’re currently experiencing service disruptions with SecureCall Services in US East Region due to an ongoing AWS outage impacting our infrastructure.