SecureCall - Webex in the US – Incident details

All systems operational

Webex in the US

Resolved
Degraded performance
Started 7 days agoLasted about 8 hours

Affected

Payment Services

Operational from 1:44 PM to 9:40 PM

Voice Services

Degraded performance from 1:44 PM to 9:40 PM, Operational from 2:48 PM to 9:40 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Update
    Update

    Webex is currently experiencing service disruptions across the US, Canada, and EMEA regions. As a result, SecureCall operations in all affected regions may also be impacted.

  • Monitoring
    Monitoring

    Webex in the US is currently experiencing issues and is impacting SecureCall